Home  /  Questions  /  Question

50   50
Jan 03, 2013

Can't install Design Pattern Framework 4.0 C#

When I click the msi it says "Could not access network location \\epdatadep\debusers$\begin\\DoFactory Paterns 4.0 CS."  There is no ini, nor does it prompt for an install location.  How do you install it?  Notice the extra \ between begin and DoFactory. 

830   99.9
Jan 03, 2013
We solved the problem for Dean and Wayne, but I wanted to post the solution for everyone else's benefit: 


This is a know install problem related to an incorrect registry entry and having a mapped network share on your machine.
The issue is inside the MSI installer and is outside our control.

Fortunately, Glenn Long, one of our users, posted a workaround/solution:

1. Open a CMD Window
2. Execute using your own path:  

C:\> msiexec /i "Design Pattern Framework 4.0 CS.msi" TARGETDIR="C:\Personal\Design Pattern Framework 4.0 CS"

Simple adjust the MSI filename and TARGETDIR to your needs.

Hope this is helpful.

 1 comment
Cool - thank you to Glenn Long! Before I looked up this forum, I simply tried finding my botched network dir in my registry since I knew it was searching for it... but was nowhere within the registry...I assume part of my profile settings or something. Either way, install didn't work and thanks for the TARGETDIR msi reminder! :) --- Drew Bollmann  Apr 02, 2013