Back to list
Views:   33.4K
Replies:  1
Archived
Connection error message: keyword not supported: 'initial catalog'
The error occurs in the Global.asax file at the following line:

WebSecurity.InitializeDatabaseConnection("Action", "Member", "MemberId", "Email", autoCreateTables:= True)

Let me say that so far I've made a couple of changes to the web.config file after reading the material in 'Getting Started' and also 'Patterns in Action 4.5'. These changes are:

<connectionStrings>
<add name="Action" connectionString="Data Source=myServerName;Initial Catalog=Action;User ID=myUID;Password=myPWD"/>
</connectionStrings>

(I've changed the actual values, but you get the idea!)

I've also changed the <app settings> tag to the following:

<appSettings>
 <add key="DataProvider" value="ADO.NET" />
</appSettings>

Firstly, I'm not sure if I should also be changing the settings for the 'ActionEntities' connection string and if so what to.

Secondly, I'm fairly certain I was getting the same error message even before I made any changes. Can someone help?

TIA



MAI Joomun, Feb 10, 2014
Reply 1
Here is a post with a similar error message: http://stackoverflow.com/questions/8150737/asp-net-mvc3-connection-string-keyword-not-supported-initial-catalog

In their case it was the data provider that was the problem.  t would think that that is also the case here:
-First see if adding 'providerName="System.Data.SqlClient" to your connection string solves your problem.
-Secondly try changing the data provider from 'ADO.NET' to "Ado.Net" (although from what I remember case does not matter).

Hope this gets you going. 
Jack Poorte, Feb 11, 2014
Stay Inspired!
Join other developers and designers who have already signed up for our mailing list.
Terms     Privacy     Licensing       EULA       Sitemap      
© Data & Object Factory, LLC.
Made with    in Austin, Texas